2010-10-19 |
Owen Anderson | Get rid of static constructors for pass registration... |
blob | commitdiff | raw |
2010-10-07 |
Owen Anderson | Now with fewer extraneous semicolons! |
blob | commitdiff | raw | diff to current |
2010-08-06 |
Owen Anderson | Reapply r110396, with fixes to appease the Linux buildb... |
blob | commitdiff | raw | diff to current |
2010-08-06 |
Owen Anderson | Revert r110396 to fix buildbots. |
blob | commitdiff | raw | diff to current |
2010-08-05 |
Owen Anderson | Don't use PassInfo* as a type identifier for passes... |
blob | commitdiff | raw | diff to current |
2010-07-21 |
Owen Anderson | Fix batch of converting RegisterPass<> to INTIALIZE_PASS(). |
blob | commitdiff | raw | diff to current |
2009-11-01 |
Chris Lattner | cleanups, switch GlobalDCE to SmallPtrSet instead of... |
blob | commitdiff | raw | diff to current |
2009-10-29 |
Chris Lattner | teach various passes about blockaddress. We no longer |
blob | commitdiff | raw | diff to current |
2009-10-25 |
Nick Lewycky | Remove includes of Support/Compiler.h that are no longe... |
blob | commitdiff | raw | diff to current |
2009-10-25 |
Nick Lewycky | Remove VISIBILITY_HIDDEN from class/struct found inside... |
blob | commitdiff | raw | diff to current |
2009-10-21 |
Devang Patel | Derive metadata hierarchy from Value instead of User. |
blob | commitdiff | raw | diff to current |
2009-10-21 |
Devang Patel | Do not remove dead metadata for now. |
blob | commitdiff | raw | diff to current |
2009-08-11 |
Devang Patel | Remove dead metadata. |
blob | commitdiff | raw | diff to current |
2009-07-22 |
Owen Anderson | Get rid of the Pass+Context magic. |
blob | commitdiff | raw | diff to current |
2009-07-16 |
Owen Anderson | Move the ConstantInt uniquing table into LLVMContextImp... |
blob | commitdiff | raw | diff to current |
2009-06-09 |
Jay Foad | Remove an unused function SafeToDestroyConstant().... |
blob | commitdiff | raw | diff to current |
2009-05-23 |
Torok Edwin | available_externall linkage is not local, this was... |
blob | commitdiff | raw | diff to current |
2009-04-13 |
Chris Lattner | eliminate unneeded parens. |
blob | commitdiff | raw | diff to current |
2009-02-17 |
Duncan Sands | If an alias is dead and so is its aliasee, then globald... |
blob | commitdiff | raw | diff to current |
2009-01-15 |
Rafael Espindola | Add the private linkage. |
blob | commitdiff | raw | diff to current |
2009-01-07 |
Duncan Sands | The verifier checks that the aliasee is not null. |
blob | commitdiff | raw | diff to current |
2009-01-05 |
Duncan Sands | Not having an aliasee is a theoretical possibility. |
blob | commitdiff | raw | diff to current |
2009-01-05 |
Duncan Sands | Format more neatly. |
blob | commitdiff | raw | diff to current |
2009-01-05 |
Duncan Sands | Delete unused global aliases with internal linkage. |
blob | commitdiff | raw | diff to current |
2008-11-11 |
Devang Patel | Use actual function name in comments. |
blob | commitdiff | raw | diff to current |
2008-09-04 |
Dan Gohman | Tidy up several unbeseeming casts from pointer to intptr_t. |
blob | commitdiff | raw | diff to current |
2008-07-11 |
Dan Gohman | Use find instead of lower_bound. |
blob | commitdiff | raw | diff to current |
2008-05-13 |
Dan Gohman | Clean up the use of static and anonymous namespaces... |
blob | commitdiff | raw | diff to current |
2007-12-29 |
Chris Lattner | Remove attribution from file headers, per discussion... |
blob | commitdiff | raw | diff to current |
2007-05-06 |
Nick Lewycky | Fix typo in comment. |
blob | commitdiff | raw | diff to current |
2007-05-03 |
Devang Patel | Drop 'const' |
blob | commitdiff | raw | diff to current |
2007-05-02 |
Devang Patel | Use 'static const char' instead of 'static const int'. |
blob | commitdiff | raw | diff to current |
2007-05-01 |
Devang Patel | Do not use typeinfo to identify pass in pass manager. |
blob | commitdiff | raw | diff to current |
2007-04-29 |
Anton Korobeynikov | Implement review feedback |
blob | commitdiff | raw | diff to current |
2007-04-28 |
Anton Korobeynikov | Implement review feedback. Aliasees can be either Globa... |
blob | commitdiff | raw | diff to current |
2007-04-25 |
Anton Korobeynikov | Implement aliases. This fixes PR1017 and it's dependent... |
blob | commitdiff | raw | diff to current |
2007-02-05 |
Reid Spencer | Apply the VISIBILITY_HIDDEN field to the remaining... |
blob | commitdiff | raw | diff to current |
2007-01-30 |
Reid Spencer | For PR1136: Rename GlobalVariable::isExternal as isDecl... |
blob | commitdiff | raw | diff to current |
2006-12-19 |
Chris Lattner | Eliminate static ctors due to Statistic objects |
blob | commitdiff | raw | diff to current |
2006-12-06 |
Chris Lattner | Detemplatize the Statistic class. The only type it... |
blob | commitdiff | raw | diff to current |
2006-08-27 |
Chris Lattner | eliminate RegisterOpt. It does the same thing as Regis... |
blob | commitdiff | raw | diff to current |
2005-04-21 |
Misha Brukman | Remove trailing whitespace |
blob | commitdiff | raw | diff to current |
2005-03-15 |
Chris Lattner | This mega patch converts us from using Function::a... |
blob | commitdiff | raw | diff to current |
2004-09-20 |
Chris Lattner | 'Pass' should now not be derived from by clients. ... |
blob | commitdiff | raw | diff to current |
2004-09-01 |
Reid Spencer | Changes For Bug 352 |
blob | commitdiff | raw | diff to current |
2004-07-18 |
Chris Lattner | Remove useless statistic, fix some slightly broken... |
blob | commitdiff | raw | diff to current |
2004-07-18 |
Reid Spencer | bug 122: |
blob | commitdiff | raw | diff to current |
2003-11-21 |
Chris Lattner | Finegrainify namespacification |
blob | commitdiff | raw | diff to current |
2003-11-11 |
Brian Gaeke | Put all LLVM code into the llvm namespace, as per bug... |
blob | commitdiff | raw | diff to current |
2003-10-20 |
John Criswell | Added LLVM project notice to the top of every C++ sourc... |
blob | commitdiff | raw | diff to current |
2003-09-20 |
Chris Lattner | Global variables with APPENDING linkage are very import... |
blob | commitdiff | raw | diff to current |
2003-09-16 |
Chris Lattner | This is effectively a complete rewrite of the globaldce... |
blob | commitdiff | raw | diff to current |
2003-09-15 |
Chris Lattner | Ugh, a bug fix needed because of the bug in the CallGra... |
blob | commitdiff | raw | diff to current |
2003-08-07 |
John Criswell | Fixed a segfault in gccld. |
blob | commitdiff | raw | diff to current |
2003-06-26 |
Chris Lattner | Add support to globaldce for deleting dead function... |
blob | commitdiff | raw | diff to current |
2002-10-13 |
Chris Lattner | Use methods that are more explanatory |
blob | commitdiff | raw | diff to current |
2002-10-01 |
Chris Lattner | Updates to work with recent Statistic's changes: |
blob | commitdiff | raw | diff to current |
2002-08-18 |
Chris Lattner | - Made GlobalDCE worklist driven, making it more... |
blob | commitdiff | raw | diff to current |
2002-08-08 |
Chris Lattner | - Cleaned up the interface to AnalysisUsage to take... |
blob | commitdiff | raw | diff to current |
2002-07-26 |
Chris Lattner | * Add support for different "PassType's" |
blob | commitdiff | raw | diff to current |
2002-07-24 |
Chris Lattner | Eliminate several include/llvm/Transforms/IPO/*.h files... |
blob | commitdiff | raw | diff to current |
2002-07-23 |
Chris Lattner | *** empty log message *** |
blob | commitdiff | raw | diff to current |
2002-07-18 |
Chris Lattner | Seperate stats for DCE'd functions and vars |
blob | commitdiff | raw | diff to current |
2002-07-18 |
Chris Lattner | *** empty log message *** |
blob | commitdiff | raw | diff to current |
2002-06-25 |
Chris Lattner | MEGAPATCH checkin. |
blob | commitdiff | raw | diff to current |
2002-05-10 |
Chris Lattner | Add support for printing out statistics information... |
blob | commitdiff | raw | diff to current |
2002-04-29 |
Chris Lattner | Eliminate dead global variables |
blob | commitdiff | raw | diff to current |
2002-04-29 |
Chris Lattner | Eliminate duplicate or unneccesary #include's |
blob | commitdiff | raw | diff to current |
2002-04-29 |
Chris Lattner | Add new optional getPassName() virtual function that... |
blob | commitdiff | raw | diff to current |
2002-04-27 |
Chris Lattner | * Rename MethodPass class to FunctionPass |
blob | commitdiff | raw | diff to current |
2002-04-07 |
Chris Lattner | Change references to the Method class to be references... |
blob | commitdiff | raw | diff to current |
2002-03-06 |
Chris Lattner | Take CallGraph out of the CFG namespace. It has nothin... |
blob | commitdiff | raw | diff to current |
2002-02-26 |
Chris Lattner | Change over to use new style pass mechanism, now passes... |
blob | commitdiff | raw | diff to current |
2002-01-31 |
Chris Lattner | Convert xforms over to new pass structure. |
blob | commitdiff | raw | diff to current |
2002-01-21 |
Chris Lattner | Implement a more powerful, simpler, pass system. This... |
blob | commitdiff | raw | diff to current |
2002-01-20 |
Chris Lattner | Changes to build successfully with GCC 3.02 |
blob | commitdiff | raw | diff to current |
2001-11-27 |
Chris Lattner | Create a new #include "Support/..." directory structure... |
blob | commitdiff | raw | diff to current |
2001-11-26 |
Chris Lattner | Implement DCE of global values |
blob | commitdiff | raw | diff to current |
|