For PR723:
[oota-llvm.git] / llvm.spec
1 Summary: Static and JIT research compiler infrastructure
2 Name: llvm
3 Version: 1.6cvs
4 Release: 0
5 License: U of Illinois/NCSA Open Source License
6 Group: Development/Languages
7 Source0: llvm.tar.gz
8 URL: http://llvm.cs.uiuc.edu/releases/index.html
9 #BuildRequires: llvm-gcc
10 # (someday...)
11 BuildRoot: %{_tmppath}/%{name}-root
12 Requires: /sbin/ldconfig
13
14 %description
15 LLVM is a compiler infrastructure designed for compile-time, link-time, runtime,
16 and "idle-time" optimization of programs from arbitrary programming languages.
17 LLVM is written in C++ and has been developed since 2000 at the University of
18 Illinois. It currently supports compilation of C and C++ programs, using
19 front-ends derived from GCC 3.4. The compiler infrastructure includes mirror
20 sets of programming tools as well as libraries with equivalent
21 functionality.
22
23 %prep
24 %setup -q -n llvm
25
26 %build
27 ./configure \
28 --prefix=%{_prefix} \
29 --bindir=%{_bindir} \
30 --datadir=%{_datadir} \
31 --includedir=%{_includedir} \
32 --libdir=%{_libdir} \
33 --enable-optimized \
34 --enable-assertions \
35 make
36
37 %install
38 rm -rf %{buildroot}
39 make install DESTDIR=%{buildroot}
40
41 %clean
42 rm -rf %{buildroot}
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48 %files
49 %defattr(-, root, root)
50 %doc CREDITS.TXT LICENSE.TXT README.txt docs/*.{html,css,gif,jpg} docs/CommandGuide
51 %{_bindir}/*
52 %{_libdir}/*.o
53 %{_libdir}/*.a
54 %{_libdir}/*.so
55 %{_includedir}/llvm
56
57 %changelog
58 * Fri Apr 07 2006 Reid Spencer
59 - Make the build be optimized+assertions
60 * Fri May 13 2005 Reid Spencer
61 - Minor adjustments for the 1.5 release
62 * Mon Feb 09 2003 Brian R. Gaeke
63 - Initial working version of RPM spec file.
64