Raise the minimum CMake version to 2.8.8 -- we have a report that the
authorChandler Carruth <chandlerc@gmail.com>
Mon, 13 Jan 2014 22:05:20 +0000 (22:05 +0000)
committerChandler Carruth <chandlerc@gmail.com>
Mon, 13 Jan 2014 22:05:20 +0000 (22:05 +0000)
compiler version checking doesn't work on 2.8.7. This feature was
documented in 2.8.10, but existed for an unknown amount of time before
that.

I'm actually happy to revert this and remove the use of the feature if
there is anyone with a specific problem updating CMake. Please just let
me know. I don't want to re-implement this CMake functionality unless
there is a reason, and this is the only real way to find that out.

git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@199148 91177308-0d34-0410-b5e6-96231b3b80d8

CMakeLists.txt

index 949abe1..06f4335 100644 (file)
@@ -1,7 +1,7 @@
 # See docs/CMake.html for instructions about how to build LLVM with CMake.
 
 project(LLVM)
-cmake_minimum_required(VERSION 2.8)
+cmake_minimum_required(VERSION 2.8.8)
 
 # Add path for custom modules
 set(CMAKE_MODULE_PATH