LLVM_ENABLE_MODULES: No need to set -fcxx-modules in trunk, just -fmodules.
authorNAKAMURA Takumi <geek4civic@gmail.com>
Fri, 13 Nov 2015 01:26:31 +0000 (01:26 +0000)
committerNAKAMURA Takumi <geek4civic@gmail.com>
Fri, 13 Nov 2015 01:26:31 +0000 (01:26 +0000)
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@252996 91177308-0d34-0410-b5e6-96231b3b80d8

cmake/modules/HandleLLVMOptions.cmake

index db0abb6..82a4084 100644 (file)
@@ -433,7 +433,7 @@ elseif( LLVM_COMPILER_IS_GCC_COMPATIBLE )
   endif()
   if (LLVM_ENABLE_MODULES)
     set(OLD_CMAKE_REQUIRED_FLAGS ${CMAKE_REQUIRED_FLAGS})
-    set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -fmodules -fcxx-modules")
+    set(CMAKE_REQUIRED_FLAGS "${CMAKE_REQUIRED_FLAGS} -fmodules")
     # Check that we can build code with modules enabled, and that repeatedly
     # including <cassert> still manages to respect NDEBUG properly.
     CHECK_CXX_SOURCE_COMPILES("#undef NDEBUG