Expose LLVM version string via macro in llvm-config.h, and modify Go bindings
authorPeter Collingbourne <peter@pcc.me.uk>
Wed, 19 Nov 2014 03:34:17 +0000 (03:34 +0000)
committerPeter Collingbourne <peter@pcc.me.uk>
Wed, 19 Nov 2014 03:34:17 +0000 (03:34 +0000)
to make use of it.

git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@222307 91177308-0d34-0410-b5e6-96231b3b80d8

autoconf/configure.ac
bindings/go/build.sh
bindings/go/llvm/version.go
configure
include/llvm/Config/config.h.in
include/llvm/Config/llvm-config.h.cmake
include/llvm/Config/llvm-config.h.in

index 31d462b..ca6d710 100644 (file)
@@ -42,6 +42,7 @@ LLVM_VERSION_SUFFIX=svn
 AC_DEFINE_UNQUOTED([LLVM_VERSION_MAJOR], $LLVM_VERSION_MAJOR, [Major version of the LLVM API])
 AC_DEFINE_UNQUOTED([LLVM_VERSION_MINOR], $LLVM_VERSION_MINOR, [Minor version of the LLVM API])
 AC_DEFINE_UNQUOTED([LLVM_VERSION_PATCH], $LLVM_VERSION_PATCH, [Patch version of the LLVM API])
+AC_DEFINE_UNQUOTED([LLVM_VERSION_STRING], "$PACKAGE_VERSION", [LLVM version string])
 
 AC_SUBST([LLVM_VERSION_MAJOR])
 AC_SUBST([LLVM_VERSION_MINOR])
index 3f0be00..3177852 100755 (executable)
@@ -26,6 +26,3 @@ else
 fi
 
 $llvm_go print-config > $gollvmdir/llvm_config.go
-
-llvm_version="$($llvm_config --version)"
-printf "package llvm\n\nconst Version = \"%s\"\n" "$llvm_version" > $gollvmdir/version.go
index 5938583..d0623be 100644 (file)
@@ -1,3 +1,21 @@
+//===- version.go - LLVM version info -------------------------------------===//
+//
+//                     The LLVM Compiler Infrastructure
+//
+// This file is distributed under the University of Illinois Open Source
+// License. See LICENSE.TXT for details.
+//
+//===----------------------------------------------------------------------===//
+//
+// This file defines LLVM version information.
+//
+//===----------------------------------------------------------------------===//
+
 package llvm
 
-const Version = "3.6.0svn"
+/*
+#include "llvm/Config/llvm-config.h"
+*/
+import "C"
+
+const Version = C.LLVM_VERSION_STRING
index 597d119..4bfc2e5 100755 (executable)
--- a/configure
+++ b/configure
@@ -1941,6 +1941,11 @@ cat >>confdefs.h <<_ACEOF
 _ACEOF
 
 
+cat >>confdefs.h <<_ACEOF
+#define LLVM_VERSION_STRING "$PACKAGE_VERSION"
+_ACEOF
+
+
 
 
 
index beed118..8fcf145 100644 (file)
 /* Patch version of the LLVM API */
 #undef LLVM_VERSION_PATCH
 
+/* LLVM version string */
+#undef LLVM_VERSION_STRING
+
 /* The shared library extension */
 #undef LTDL_SHLIB_EXT
 
index 5811164..77201e6 100644 (file)
@@ -92,6 +92,9 @@
 /* Minor version of the LLVM API */
 #cmakedefine LLVM_VERSION_MINOR ${LLVM_VERSION_MINOR}
 
+/* LLVM version string */
+#define LLVM_VERSION_STRING "${PACKAGE_VERSION}"
+
 /* Define if we link Polly to the tools */
 #cmakedefine LINK_POLLY_INTO_TOOLS
 
index 5656240..2d6add7 100644 (file)
@@ -92,4 +92,7 @@
 /* Minor version of the LLVM API */
 #undef LLVM_VERSION_MINOR
 
+/* LLVM version string */
+#undef LLVM_VERSION_STRING
+
 #endif