The new isel passes all tests, time to start making it go fast.
[oota-llvm.git] / utils / TableGen / CMakeLists.txt
index d9ec6f7d1a1d8edd81070876efa83e707fcbedad..881b50a01faf150373ec614e0a0f29f82fb39195 100644 (file)
@@ -1,6 +1,7 @@
 add_executable(tblgen
   AsmMatcherEmitter.cpp
   AsmWriterEmitter.cpp
+  AsmWriterInst.cpp
   CallingConvEmitter.cpp
   ClangDiagnosticsEmitter.cpp
   CodeEmitterGen.cpp
@@ -8,6 +9,12 @@ add_executable(tblgen
   CodeGenInstruction.cpp
   CodeGenTarget.cpp
   DAGISelEmitter.cpp
+  DAGISelMatcherEmitter.cpp
+  DAGISelMatcherGen.cpp
+  DAGISelMatcherOpt.cpp
+  DAGISelMatcher.cpp
+  DisassemblerEmitter.cpp
+  EDEmitter.cpp
   FastISelEmitter.cpp
   InstrEnumEmitter.cpp
   InstrInfoEmitter.cpp
@@ -22,6 +29,8 @@ add_executable(tblgen
   TGValueTypes.cpp
   TableGen.cpp
   TableGenBackend.cpp
+  X86DisassemblerTables.cpp
+  X86RecognizableInstr.cpp
   )
 
 target_link_libraries(tblgen LLVMSupport LLVMSystem)