The new isel passes all tests, time to start making it go fast.
[oota-llvm.git] / utils / TableGen / CMakeLists.txt
index 6ec1d9967922daeed9ed45f1a7a33d5012378106..881b50a01faf150373ec614e0a0f29f82fb39195 100644 (file)
@@ -1,5 +1,7 @@
 add_executable(tblgen
+  AsmMatcherEmitter.cpp
   AsmWriterEmitter.cpp
+  AsmWriterInst.cpp
   CallingConvEmitter.cpp
   ClangDiagnosticsEmitter.cpp
   CodeEmitterGen.cpp
@@ -7,11 +9,18 @@ add_executable(tblgen
   CodeGenInstruction.cpp
   CodeGenTarget.cpp
   DAGISelEmitter.cpp
+  DAGISelMatcherEmitter.cpp
+  DAGISelMatcherGen.cpp
+  DAGISelMatcherOpt.cpp
+  DAGISelMatcher.cpp
+  DisassemblerEmitter.cpp
+  EDEmitter.cpp
   FastISelEmitter.cpp
   InstrEnumEmitter.cpp
   InstrInfoEmitter.cpp
   IntrinsicEmitter.cpp
   LLVMCConfigurationEmitter.cpp
+  OptParserEmitter.cpp
   Record.cpp
   RegisterInfoEmitter.cpp
   SubtargetEmitter.cpp
@@ -20,6 +29,8 @@ add_executable(tblgen
   TGValueTypes.cpp
   TableGen.cpp
   TableGenBackend.cpp
+  X86DisassemblerTables.cpp
+  X86RecognizableInstr.cpp
   )
 
 target_link_libraries(tblgen LLVMSupport LLVMSystem)