Add support for double / float to EndianStream
[oota-llvm.git] / unittests / Support / CMakeLists.txt
index f6a5949cdb9b75cc988f66716c8517eb79073af2..f3b55c3a4172603e5c878122cd25a89e73fe411c 100644 (file)
@@ -1,31 +1,52 @@
 set(LLVM_LINK_COMPONENTS
   Support
-  Core
   )
 
 add_llvm_unittest(SupportTests
   AlignOfTest.cpp
   AllocatorTest.cpp
+  ArrayRecyclerTest.cpp
   BlockFrequencyTest.cpp
+  BranchProbabilityTest.cpp
   Casting.cpp
   CommandLineTest.cpp
-  ConstantRangeTest.cpp
+  CompressionTest.cpp
+  ConvertUTFTest.cpp
   DataExtractorTest.cpp
+  DwarfTest.cpp
+  EndianStreamTest.cpp
   EndianTest.cpp
+  ErrorOrTest.cpp
   FileOutputBufferTest.cpp
-  IntegersSubsetTest.cpp
-  LeakDetectorTest.cpp
+  IteratorTest.cpp
+  LEB128Test.cpp
+  LineIteratorTest.cpp
+  LockFileManagerTest.cpp
+  MD5Test.cpp
   ManagedStatic.cpp
   MathExtrasTest.cpp
   MemoryBufferTest.cpp
   MemoryTest.cpp
   Path.cpp
+  ProcessTest.cpp
+  ProgramTest.cpp
   RegexTest.cpp
+  ScaledNumberTest.cpp
+  SourceMgrTest.cpp
+  SpecialCaseListTest.cpp
+  StreamingMemoryObject.cpp
+  StringPool.cpp
   SwapByteOrderTest.cpp
-  TimeValue.cpp
-  ValueHandleTest.cpp
+  ThreadLocalTest.cpp
+  TimeValueTest.cpp
+  UnicodeTest.cpp
   YAMLIOTest.cpp
   YAMLParserTest.cpp
   formatted_raw_ostream_test.cpp
   raw_ostream_test.cpp
   )
+
+# ManagedStatic.cpp uses <pthread>.
+if(LLVM_ENABLE_THREADS AND HAVE_LIBPTHREAD)
+  target_link_libraries(SupportTests pthread)
+endif()