Move get[S|U]LEB128Size() to LEB128.h.
[oota-llvm.git] / unittests / Support / CMakeLists.txt
index a137052fac589d0ee1c81a95947698cae10e4140..bfbef982e2e5bd134778c6165ad82e9860c2e87c 100644 (file)
@@ -6,22 +6,37 @@ set(LLVM_LINK_COMPONENTS
 add_llvm_unittest(SupportTests
   AlignOfTest.cpp
   AllocatorTest.cpp
+  ArrayRecyclerTest.cpp
   BlockFrequencyTest.cpp
   Casting.cpp
   CommandLineTest.cpp
+  CompressionTest.cpp
   ConstantRangeTest.cpp
+  ConvertUTFTest.cpp
   DataExtractorTest.cpp
   EndianTest.cpp
+  ErrorOrTest.cpp
   FileOutputBufferTest.cpp
-  IntegersSubsetTest.cpp
+  LEB128Test.cpp
   LeakDetectorTest.cpp
+  LineIteratorTest.cpp
+  LockFileManagerTest.cpp
   ManagedStatic.cpp
   MathExtrasTest.cpp
+  MD5Test.cpp
+  MemoryBufferTest.cpp
+  MemoryTest.cpp
   Path.cpp
+  ProcessTest.cpp
+  ProgramTest.cpp
   RegexTest.cpp
+  SourceMgrTest.cpp
   SwapByteOrderTest.cpp
-  TimeValue.cpp
+  ThreadLocalTest.cpp
+  TimeValueTest.cpp
+  UnicodeTest.cpp
   ValueHandleTest.cpp
+  YAMLIOTest.cpp
   YAMLParserTest.cpp
   formatted_raw_ostream_test.cpp
   raw_ostream_test.cpp