Add mfasr and mtasr
[oota-llvm.git] / unittests / ExecutionEngine / JIT / CMakeLists.txt
index d5e0b2eea84240896c4f8a5b167bec5a272877c7..5ace1c6ee48a541901a9ede68c12cc3683eadc31 100644 (file)
@@ -5,6 +5,7 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   JIT
+  MC
   Support
   nativecodegen
   )
@@ -51,6 +52,9 @@ if(MSVC)
   list(APPEND JITTestsSources JITTests.def)
 endif()
 
+# The JIT tests need to dlopen things.
+set(LLVM_NO_DEAD_STRIP 1)
+
 add_llvm_unittest(JITTests
   ${JITTestsSources}
   )