[Orc] Move some code up into the JITCompileCallbackManager base class. NFC.
[oota-llvm.git] / unittests / ExecutionEngine / CMakeLists.txt
index 5e462220e5cd6c1a93f0894e8b55f4d4aad64738..302de9943ffe4c3e3e4095e1aab940503e57332e 100644 (file)
@@ -3,6 +3,8 @@ set(LLVM_LINK_COMPONENTS
   ExecutionEngine
   Interpreter
   MC
+  OrcJIT
+  RuntimeDyld
   Support
   )
 
@@ -10,10 +12,11 @@ add_llvm_unittest(ExecutionEngineTests
   ExecutionEngineTest.cpp
   )
 
-# Include JIT/MCJIT tests only if native arch is a built JIT target.
+add_subdirectory(Orc)
+
+# Include MCJIT tests only if native arch is a built JIT target.
 list(FIND LLVM_TARGETS_TO_BUILD "${LLVM_NATIVE_ARCH}" build_idx)
 list(FIND LLVM_TARGETS_WITH_JIT "${LLVM_NATIVE_ARCH}" jit_idx)
 if (NOT build_idx LESS 0 AND NOT jit_idx LESS 0)
-  add_subdirectory(JIT)
   add_subdirectory(MCJIT)
 endif()