[Orc] Move some code up into the JITCompileCallbackManager base class. NFC.
[oota-llvm.git] / unittests / ExecutionEngine / CMakeLists.txt
index 4eefc1e3bb1b0ddcc758cd81311005a4893dde53..302de9943ffe4c3e3e4095e1aab940503e57332e 100644 (file)
@@ -1,14 +1,22 @@
 set(LLVM_LINK_COMPONENTS
-  interpreter
+  Core
+  ExecutionEngine
+  Interpreter
+  MC
+  OrcJIT
+  RuntimeDyld
+  Support
   )
 
 add_llvm_unittest(ExecutionEngineTests
   ExecutionEngineTest.cpp
   )
 
-# Include JIT/MCJIT tests only if native arch is a JIT target.
-list(FIND LLVM_TARGETS_WITH_JIT "${LLVM_NATIVE_ARCH}" have_jit)
-if (NOT have_jit EQUAL -1 )
-  add_subdirectory(JIT)
+add_subdirectory(Orc)
+
+# Include MCJIT tests only if native arch is a built JIT target.
+list(FIND LLVM_TARGETS_TO_BUILD "${LLVM_NATIVE_ARCH}" build_idx)
+list(FIND LLVM_TARGETS_WITH_JIT "${LLVM_NATIVE_ARCH}" jit_idx)
+if (NOT build_idx LESS 0 AND NOT jit_idx LESS 0)
   add_subdirectory(MCJIT)
 endif()