[Mips64] Add support for MCJIT for MIPS64r2 and MIPS64r6
[oota-llvm.git] / unittests / ExecutionEngine / CMakeLists.txt
index 489eaaff6ad1f162bb56f741935b5b1df06de075..302de9943ffe4c3e3e4095e1aab940503e57332e 100644 (file)
@@ -2,6 +2,9 @@ set(LLVM_LINK_COMPONENTS
   Core
   ExecutionEngine
   Interpreter
+  MC
+  OrcJIT
+  RuntimeDyld
   Support
   )
 
@@ -9,10 +12,11 @@ add_llvm_unittest(ExecutionEngineTests
   ExecutionEngineTest.cpp
   )
 
-# Include JIT/MCJIT tests only if native arch is a built JIT target.
+add_subdirectory(Orc)
+
+# Include MCJIT tests only if native arch is a built JIT target.
 list(FIND LLVM_TARGETS_TO_BUILD "${LLVM_NATIVE_ARCH}" build_idx)
 list(FIND LLVM_TARGETS_WITH_JIT "${LLVM_NATIVE_ARCH}" jit_idx)
 if (NOT build_idx LESS 0 AND NOT jit_idx LESS 0)
-  add_subdirectory(JIT)
   add_subdirectory(MCJIT)
 endif()