[fuzzer] update the include line to use the new header name
[oota-llvm.git] / unittests / CMakeLists.txt
index 84685e1c24dcb2fd4dac3ccad03088a7e53124dc..19c2d24534b20bd0388299adece0a71e51c47e21 100644 (file)
@@ -1,6 +1,12 @@
 add_custom_target(UnitTests)
 set_target_properties(UnitTests PROPERTIES FOLDER "Tests")
 
+if (APPLE)
+  set(CMAKE_INSTALL_RPATH "@executable_path/../../lib")
+else(UNIX)
+  set(CMAKE_INSTALL_RPATH "\$ORIGIN/../../lib${LLVM_LIBDIR_SUFFIX}")
+endif()
+
 function(add_llvm_unittest test_dirname)
   add_unittest(UnitTests ${test_dirname} ${ARGN})
 endfunction()
@@ -13,8 +19,8 @@ add_subdirectory(DebugInfo)
 add_subdirectory(ExecutionEngine)
 add_subdirectory(IR)
 add_subdirectory(LineEditor)
+add_subdirectory(Linker)
 add_subdirectory(MC)
-add_subdirectory(Object)
 add_subdirectory(Option)
 add_subdirectory(Support)
 add_subdirectory(Transforms)