fix leak in a test, make the sanitizer bot green
[oota-llvm.git] / unittests / ADT / CMakeLists.txt
index b7d006ac66d4c2962085007f5a8da2ab4c4aba3b..cb878c61b85f04ed81a53f4fa87d684651ee2f8c 100644 (file)
@@ -5,6 +5,7 @@ set(LLVM_LINK_COMPONENTS
 set(ADTSources
   APFloatTest.cpp
   APIntTest.cpp
+  APSIntTest.cpp
   ArrayRefTest.cpp
   BitVectorTest.cpp
   DAGDeltaAlgorithmTest.cpp
@@ -12,6 +13,7 @@ set(ADTSources
   DenseMapTest.cpp
   DenseSetTest.cpp
   FoldingSet.cpp
+  FunctionRefTest.cpp
   HashingTest.cpp
   ilistTest.cpp
   ImmutableMapTest.cpp
@@ -19,11 +21,14 @@ set(ADTSources
   IntEqClassesTest.cpp
   IntervalMapTest.cpp
   IntrusiveRefCntPtrTest.cpp
+  MakeUniqueTest.cpp
   MapVectorTest.cpp
   OptionalTest.cpp
-  OwningPtrTest.cpp
   PackedVectorTest.cpp
+  PointerIntPairTest.cpp
   PointerUnionTest.cpp
+  PostOrderIteratorTest.cpp
+  RangeAdapterTest.cpp
   SCCIteratorTest.cpp
   SmallPtrSetTest.cpp
   SmallStringTest.cpp
@@ -37,18 +42,10 @@ set(ADTSources
   TripleTest.cpp
   TwineTest.cpp
   VariadicFunctionTest.cpp
-  polymorphic_ptr_test.cpp
  )
 
-# They cannot be compiled on MSVC9 due to its bug.
-if(MSVC AND MSVC_VERSION LESS 1600)
-  set(LLVM_OPTIONAL_SOURCES
-    DenseMapTest.cpp
-    SmallVectorTest.cpp
-    )
-  list(REMOVE_ITEM ADTSources ${LLVM_OPTIONAL_SOURCES})
-endif()
-
 add_llvm_unittest(ADTTests
   ${ADTSources}
   )
+
+add_dependencies(ADTTests intrinsics_gen)