CMake: Get rid of LLVMLibDeps.cmake and export the libraries normally.
[oota-llvm.git] / tools / opt / CMakeLists.txt
index efcca80ddfc21bbb0c45b5c76c418857f2abb891..5eff9d80f9ae82cc97877941caa31b6c26881ce3 100644 (file)
@@ -1,9 +1,15 @@
-set(LLVM_REQUIRES_EH 1)
-set(LLVM_LINK_COMPONENTS bitreader bitwriter instrumentation scalaropts ipo)
-
 add_llvm_tool(opt
   AnalysisWrappers.cpp
   GraphPrinters.cpp
   PrintSCC.cpp
   opt.cpp
   )
+
+target_link_libraries(opt
+  LLVMBitReader
+  LLVMAsmParser
+  LLVMBitWriter
+  LLVMInstrumentation
+  LLVMScalarOpts
+  LLVMipo
+  )