Split out the IRReader header and the utility functions it provides into
[oota-llvm.git] / tools / opt / CMakeLists.txt
index 0570d0e04af799d63c79b509b2f0c2bcbe97085e..1ff8efbed02fde910ae255b37fdc3825dc549ea1 100644 (file)
@@ -1,4 +1,4 @@
-set(LLVM_LINK_COMPONENTS bitreader asmparser bitwriter instrumentation scalaropts ipo)
+set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} bitreader asmparser bitwriter irreader instrumentation scalaropts objcarcopts ipo vectorize)
 
 add_llvm_tool(opt
   AnalysisWrappers.cpp