Move LTO support library to a component, allowing it to be tested
[oota-llvm.git] / tools / lto / CMakeLists.txt
index c71aac1eecab72921c860974a6014c09fb2ff11e..8b26ddd57e8879693b12bf3b865477093c985e52 100644 (file)
@@ -1,14 +1,12 @@
 set(LLVM_LINK_COMPONENTS
   ${LLVM_TARGETS_TO_BUILD}
-  ipo scalaropts linker bitreader bitwriter mcdisassembler vectorize)
+  ipo scalaropts linker bitreader bitwriter lto mcdisassembler vectorize)
 
 add_definitions( -DLLVM_VERSION_INFO=\"${PACKAGE_VERSION}\" )
 
 set(SOURCES
-  LTOCodeGenerator.cpp
   LTODisassembler.cpp
   lto.cpp
-  LTOModule.cpp
   )
 
 if( NOT WIN32 AND LLVM_ENABLE_PIC )