Merging r259342 (with s/p2align 4/align 16) because r258750 is not in 3.8.
[oota-llvm.git] / tools / llvm-pdbdump / CMakeLists.txt
index bc1c0f8c39cffb9205a80c103cfe68b365885e50..1907f917079ae6284f6804287297a177301d6bac 100644 (file)
@@ -1,26 +1,18 @@
-set(MSVC_DIA_SDK_DIR "$ENV{VSINSTALLDIR}DIA SDK")\r
-\r
-# Due to a bug in MSVC 2013's installation software, it is possible\r
-# for MSVC 2013 to write the DIA SDK into the Visual Studio 2012\r
-# install directory.  If this happens, the installation is corrupt\r
-# and there's nothing we can do.  It happens with enough frequency\r
-# though that we should handle it.  We do so by simply checking that\r
-# the DIA SDK folder exists.  Should this happen you will need to\r
-# uninstall VS 2012 and then re-install VS 2013.\r
-if (IS_DIRECTORY ${MSVC_DIA_SDK_DIR})\r
-  set(LLVM_LINK_COMPONENTS\r
-    Support\r
-    )\r
-\r
-  include_directories(${MSVC_DIA_SDK_DIR}/include)\r
-  if (CMAKE_SIZEOF_VOID_P EQUAL 8)\r
-    link_directories(${MSVC_DIA_SDK_DIR}/lib/amd64)\r
-  else()\r
-    link_directories(${MSVC_DIA_SDK_DIR}/lib)\r
-  endif()\r
-\r
-  add_llvm_tool(llvm-pdbdump\r
-    llvm-pdbdump.cpp\r
-    )\r
-  target_link_libraries(llvm-pdbdump diaguids)\r
-endif()\r
+set(LLVM_LINK_COMPONENTS
+  Support
+  DebugInfoPDB
+  )
+
+add_llvm_tool(llvm-pdbdump
+  llvm-pdbdump.cpp
+  BuiltinDumper.cpp
+  ClassDefinitionDumper.cpp
+  CompilandDumper.cpp
+  EnumDumper.cpp
+  ExternalSymbolDumper.cpp
+  FunctionDumper.cpp
+  LinePrinter.cpp
+  TypeDumper.cpp
+  TypedefDumper.cpp
+  VariableDumper.cpp
+  )