Move LTO support library to a component, allowing it to be tested
[oota-llvm.git] / tools / llvm-lto / CMakeLists.txt
index b253b69c1bc1be30cb2eee2a899de771db919a58..348976cb811fbd5b45d12de5c8e8e328234b0736 100644 (file)
@@ -1,7 +1,6 @@
+set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} lto support)
+
 add_llvm_tool(llvm-lto
   llvm-lto.cpp
   )
 
-target_link_libraries(llvm-lto LTO LLVMSupport)
-
-add_dependencies(llvm-lto lto)