[CMake] Update LLVM_LINK_COMPONENTS for each CMakeLists.txt.
[oota-llvm.git] / tools / llvm-as / CMakeLists.txt
index eef4a13e29dcc22aa7b04c11965ba062a62cffd2..1b2789a4de41fa2781aaba4517cc257650c9179b 100644 (file)
@@ -1,5 +1,9 @@
-set(LLVM_LINK_COMPONENTS asmparser bitwriter)
-set(LLVM_REQUIRES_EH 1)
+set(LLVM_LINK_COMPONENTS
+  AsmParser
+  BitWriter
+  Core
+  Support
+  )
 
 add_llvm_tool(llvm-as
   llvm-as.cpp