[Orc] Add an Orc layer for applying arbitrary transforms to IR, use it to add
[oota-llvm.git] / tools / lli / CMakeLists.txt
index 4514da01a330d7985f6883c98cc80a99d776eab9..f98275b5fe6c59863ed89db41e9b76a224e27bef 100644 (file)
@@ -1,5 +1,43 @@
-set(LLVM_LINK_COMPONENTS jit interpreter nativecodegen bitreader asmparser selectiondag)
+add_subdirectory(ChildTarget)
+
+set(LLVM_LINK_COMPONENTS
+  CodeGen
+  Core
+  ExecutionEngine
+  IRReader
+  Instrumentation
+  Interpreter
+  MC
+  MCJIT
+  Object
+  OrcJIT
+  RuntimeDyld
+  SelectionDAG
+  Support
+  native
+  )
+
+if( LLVM_USE_OPROFILE )
+  set(LLVM_LINK_COMPONENTS
+    ${LLVM_LINK_COMPONENTS}
+    OProfileJIT
+    )
+endif( LLVM_USE_OPROFILE )
+
+if( LLVM_USE_INTEL_JITEVENTS )
+  set(LLVM_LINK_COMPONENTS
+    ${LLVM_LINK_COMPONENTS}
+    DebugInfoDWARF
+    IntelJITEvents
+    Object
+    )
+endif( LLVM_USE_INTEL_JITEVENTS )
 
 add_llvm_tool(lli
   lli.cpp
+  OrcLazyJIT.cpp
+  RemoteMemoryManager.cpp
+  RemoteTarget.cpp
+  RemoteTargetExternal.cpp
   )
+export_executable_symbols(lli)