[Orc] New JIT APIs.
[oota-llvm.git] / tools / lli / CMakeLists.txt
index da48e6d215cf2576a7af7c8c9cc228f76a46b6f3..9217c382a98d54932153619d3057392388667668 100644 (file)
@@ -1,8 +1,21 @@
-
-set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser irreader selectiondag native instrumentation)
-
 add_subdirectory(ChildTarget)
 
+set(LLVM_LINK_COMPONENTS
+  CodeGen
+  Core
+  ExecutionEngine
+  IRReader
+  Instrumentation
+  Interpreter
+  MC
+  MCJIT
+  Object
+  OrcJIT
+  SelectionDAG
+  Support
+  native
+  )
+
 if( LLVM_USE_OPROFILE )
   set(LLVM_LINK_COMPONENTS
     ${LLVM_LINK_COMPONENTS}