[Orc] New JIT APIs.
[oota-llvm.git] / tools / lli / CMakeLists.txt
index aaa6598e7118a005352edafd8afa338142c7827a..9217c382a98d54932153619d3057392388667668 100644 (file)
@@ -1,5 +1,20 @@
+add_subdirectory(ChildTarget)
 
-set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser irreader selectiondag native)
+set(LLVM_LINK_COMPONENTS
+  CodeGen
+  Core
+  ExecutionEngine
+  IRReader
+  Instrumentation
+  Interpreter
+  MC
+  MCJIT
+  Object
+  OrcJIT
+  SelectionDAG
+  Support
+  native
+  )
 
 if( LLVM_USE_OPROFILE )
   set(LLVM_LINK_COMPONENTS
@@ -19,6 +34,8 @@ endif( LLVM_USE_INTEL_JITEVENTS )
 
 add_llvm_tool(lli
   lli.cpp
-  RecordingMemoryManager.cpp
+  RemoteMemoryManager.cpp
   RemoteTarget.cpp
+  RemoteTargetExternal.cpp
   )
+set_target_properties(lli PROPERTIES ENABLE_EXPORTS 1)