[Orc] New JIT APIs.
[oota-llvm.git] / tools / lli / CMakeLists.txt
index a5d2e61ea24c3fcce7ffc47e581ca926abe411df..9217c382a98d54932153619d3057392388667668 100644 (file)
@@ -1,7 +1,20 @@
+add_subdirectory(ChildTarget)
 
-link_directories( ${LLVM_INTEL_JITEVENTS_LIBDIR} )
-
-set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser selectiondag)
+set(LLVM_LINK_COMPONENTS
+  CodeGen
+  Core
+  ExecutionEngine
+  IRReader
+  Instrumentation
+  Interpreter
+  MC
+  MCJIT
+  Object
+  OrcJIT
+  SelectionDAG
+  Support
+  native
+  )
 
 if( LLVM_USE_OPROFILE )
   set(LLVM_LINK_COMPONENTS
@@ -13,10 +26,16 @@ endif( LLVM_USE_OPROFILE )
 if( LLVM_USE_INTEL_JITEVENTS )
   set(LLVM_LINK_COMPONENTS
     ${LLVM_LINK_COMPONENTS}
+    DebugInfo
     IntelJITEvents
+    Object
     )
 endif( LLVM_USE_INTEL_JITEVENTS )
 
 add_llvm_tool(lli
   lli.cpp
+  RemoteMemoryManager.cpp
+  RemoteTarget.cpp
+  RemoteTargetExternal.cpp
   )
+set_target_properties(lli PROPERTIES ENABLE_EXPORTS 1)