[Orc] New JIT APIs.
[oota-llvm.git] / tools / lli / CMakeLists.txt
index 841a0ce42f80d6598154af8819bdbca66df7a00d..9217c382a98d54932153619d3057392388667668 100644 (file)
@@ -1,6 +1,20 @@
 add_subdirectory(ChildTarget)
 
-set(LLVM_LINK_COMPONENTS mcjit jit interpreter nativecodegen bitreader asmparser irreader selectiondag native instrumentation)
+set(LLVM_LINK_COMPONENTS
+  CodeGen
+  Core
+  ExecutionEngine
+  IRReader
+  Instrumentation
+  Interpreter
+  MC
+  MCJIT
+  Object
+  OrcJIT
+  SelectionDAG
+  Support
+  native
+  )
 
 if( LLVM_USE_OPROFILE )
   set(LLVM_LINK_COMPONENTS