Revert "[asan-assembly-instrumentation] Prologue and epilogue are moved out from...
[oota-llvm.git] / tools / llc / CMakeLists.txt
index 683f29862d5c21ca639ef4e8a46242601372c0ba..393d64c0ef086e29b964337f2c26aeb59f5f1abe 100644 (file)
@@ -1,5 +1,20 @@
-set(LLVM_LINK_COMPONENTS ${LLVM_TARGETS_TO_BUILD} bitreader asmparser)
+set(LLVM_LINK_COMPONENTS
+  ${LLVM_TARGETS_TO_BUILD}
+  AsmPrinter
+  CodeGen
+  Core
+  IRReader
+  MC
+  ScalarOpts
+  SelectionDAG
+  Support
+  Target
+  )
+
+# Support plugins.
+set(LLVM_NO_DEAD_STRIP 1)
 
 add_llvm_tool(llc
   llc.cpp
   )
+set_target_properties(llc PROPERTIES ENABLE_EXPORTS 1)