static link polly into tools
[oota-llvm.git] / tools / bugpoint / CMakeLists.txt
index b537a5d237d8ba88326c18f434ebcaaa60cc62d9..d71e097918c40d47785d3dd2d55446501107dd7b 100644 (file)
@@ -32,3 +32,12 @@ add_llvm_tool(bugpoint
   bugpoint.cpp
   )
 set_target_properties(bugpoint PROPERTIES ENABLE_EXPORTS 1)
+
+if(WITH_POLLY AND LINK_POLLY_INTO_TOOLS)
+  target_link_libraries(bugpoint Polly)
+  if(POLLY_LINK_LIBS)
+    foreach(lib ${POLLY_LINK_LIBS})
+      target_link_libraries(bugpoint ${lib})
+    endforeach(lib)
+  endif(POLLY_LINK_LIBS)
+endif(WITH_POLLY AND LINK_POLLY_INTO_TOOLS)