[CMake] Add lto subdirectory explicitly.
[oota-llvm.git] / tools / CMakeLists.txt
index 71af21278101ef81bdcbbda52419e2b0c0a10f47..aca4350fcb286d07c7f141c99ba8d46469641d96 100644 (file)
@@ -30,6 +30,17 @@ if(CYGWIN OR NOT LLVM_ENABLE_PIC)
   set(LLVM_TOOL_LLVM_LTO_BUILD Off)
 endif()
 
+# Add LTO before clang, ExternalProject requires targets specified in DEPENDS
+# to exist before the call to ExternalProject_Add
+add_llvm_tool_subdirectory(lto)
+
+# Projects supported via LLVM_EXTERNAL_*_SOURCE_DIR need to be explicitly
+# specified.
+add_llvm_external_project(clang)
+add_llvm_external_project(llgo)
+add_llvm_external_project(lld)
+add_llvm_external_project(lldb)
+
 # Automatically add remaining sub-directories containing a 'CMakeLists.txt'
 # file as external projects.
 add_llvm_implicit_projects()