test/DebugInfo/ARM/prologue_end.ll references thumbv1, which is invalid.
[oota-llvm.git] / tools / CMakeLists.txt
index aca4350fcb286d07c7f141c99ba8d46469641d96..85b01c312cf2eacfdc3b903bc345717f9539f788 100644 (file)
@@ -25,14 +25,16 @@ if(NOT LLVM_USE_INTEL_JITEVENTS )
   set(LLVM_TOOL_LLVM_JITLISTENER_BUILD Off)
 endif()
 
-if(CYGWIN OR NOT LLVM_ENABLE_PIC)
+if(CYGWIN)
   set(LLVM_TOOL_LTO_BUILD Off)
   set(LLVM_TOOL_LLVM_LTO_BUILD Off)
 endif()
 
-# Add LTO before clang, ExternalProject requires targets specified in DEPENDS
-# to exist before the call to ExternalProject_Add
+# Add LTO, llvm-ar, and llvm-config before clang, ExternalProject requires
+# targets specified in DEPENDS to exist before the call to ExternalProject_Add.
 add_llvm_tool_subdirectory(lto)
+add_llvm_tool_subdirectory(llvm-ar)
+add_llvm_tool_subdirectory(llvm-config)
 
 # Projects supported via LLVM_EXTERNAL_*_SOURCE_DIR need to be explicitly
 # specified.