[Orc] Add a JITSymbol class to the Orc APIs, refactor APIs, update clients.
[oota-llvm.git] / tools / CMakeLists.txt
index 9ea5543a0b32209890c8292a1f03ad0adef4a89c..26d2dfde931a09573a8ac9b007a51be367edee63 100644 (file)
@@ -36,6 +36,7 @@ add_llvm_tool_subdirectory(llvm-objdump)
 add_llvm_tool_subdirectory(llvm-readobj)
 add_llvm_tool_subdirectory(llvm-rtdyld)
 add_llvm_tool_subdirectory(llvm-dwarfdump)
+add_llvm_tool_subdirectory(dsymutil)
 add_llvm_tool_subdirectory(llvm-vtabledump)
 if( LLVM_USE_INTEL_JITEVENTS )
   add_llvm_tool_subdirectory(llvm-jitlistener)
@@ -60,6 +61,15 @@ add_llvm_tool_subdirectory(yaml2obj)
 
 add_llvm_tool_subdirectory(llvm-go)
 
+if(MSVC AND NOT(MSVC_VERSION LESS 1800))
+  # Certain aspects of llvm-pdbdump require language support only present in
+  # MSVC 2013 and higher.  Since this is strictly a utility, and since we hope
+  # to drop support for MSVC 2012 soon, don't build this for MSVC < 2013.
+  add_llvm_tool_subdirectory(llvm-pdbdump)
+else()
+  ignore_llvm_tool_subdirectory(llvm-pdbdump)
+endif()
+
 if(NOT CYGWIN AND LLVM_ENABLE_PIC)
   add_llvm_tool_subdirectory(lto)
   add_llvm_tool_subdirectory(llvm-lto)