Reapply "[dsymutil] Gather function ranges during DIE selection."
[oota-llvm.git] / tools / CMakeLists.txt
index 26d2dfde931a09573a8ac9b007a51be367edee63..1f415b620dfcb1a9386e855545caece010e27290 100644 (file)
@@ -61,14 +61,7 @@ add_llvm_tool_subdirectory(yaml2obj)
 
 add_llvm_tool_subdirectory(llvm-go)
 
-if(MSVC AND NOT(MSVC_VERSION LESS 1800))
-  # Certain aspects of llvm-pdbdump require language support only present in
-  # MSVC 2013 and higher.  Since this is strictly a utility, and since we hope
-  # to drop support for MSVC 2012 soon, don't build this for MSVC < 2013.
-  add_llvm_tool_subdirectory(llvm-pdbdump)
-else()
-  ignore_llvm_tool_subdirectory(llvm-pdbdump)
-endif()
+add_llvm_tool_subdirectory(llvm-pdbdump)
 
 if(NOT CYGWIN AND LLVM_ENABLE_PIC)
   add_llvm_tool_subdirectory(lto)