[CMake] We need to explicitly add llvm-config before clang so that LLVM_BUILD_EXTERNA...
[oota-llvm.git] / tools / CMakeLists.txt
index 71af21278101ef81bdcbbda52419e2b0c0a10f47..1b57d7abd13a53972a91509c5606edf45a80962f 100644 (file)
@@ -30,6 +30,19 @@ if(CYGWIN OR NOT LLVM_ENABLE_PIC)
   set(LLVM_TOOL_LLVM_LTO_BUILD Off)
 endif()
 
+# Add LTO, llvm-ar, and llvm-config before clang, ExternalProject requires
+# targets specified in DEPENDS to exist before the call to ExternalProject_Add.
+add_llvm_tool_subdirectory(lto)
+add_llvm_tool_subdirectory(llvm-ar)
+add_llvm_tool_subdirectory(llvm-config)
+
+# Projects supported via LLVM_EXTERNAL_*_SOURCE_DIR need to be explicitly
+# specified.
+add_llvm_external_project(clang)
+add_llvm_external_project(llgo)
+add_llvm_external_project(lld)
+add_llvm_external_project(lldb)
+
 # Automatically add remaining sub-directories containing a 'CMakeLists.txt'
 # file as external projects.
 add_llvm_implicit_projects()