Revert "[CMake] Cleanup tools/CMakeLists.txt to take advantage of the auto-registrati...
[oota-llvm.git] / tools / CMakeLists.txt
index 71af21278101ef81bdcbbda52419e2b0c0a10f47..c9c5a1fdfa083db426996593807812b6ecd2b1f5 100644 (file)
@@ -1,37 +1,85 @@
-# This file will recurse into all subdirectories that contain CMakeLists.txt
-# Setting variables that match the pattern LLVM_TOOL_{NAME}_BUILD to Off will
-# prevent traversing into a directory.
-#
-# The only tools that need to be explicitly added are ones that have explicit
-# ordering requirements.
-
-# Iterates all the subdirectories to create CMake options to enable/disable
-# traversing each directory.
-create_llvm_tool_options()
+add_llvm_tool_subdirectory(llvm-config)
 
 # Build polly before the tools: the tools link against polly when
 # LINK_POLLY_INTO_TOOLS is set.
 if(WITH_POLLY)
   add_llvm_external_project(polly)
+else(WITH_POLLY)
+  list(APPEND LLVM_IMPLICIT_PROJECT_IGNORE "${LLVM_MAIN_SRC_DIR}/tools/polly")
+endif(WITH_POLLY)
+
+if( LLVM_BUILD_LLVM_DYLIB )
+  add_llvm_tool_subdirectory(llvm-shlib)
 else()
-  set(LLVM_TOOL_POLLY_BUILD Off)
+  ignore_llvm_tool_subdirectory(llvm-shlib)
 endif()
 
-if(NOT LLVM_BUILD_LLVM_DYLIB )
-  set(LLVM_TOOL_LLVM_SHLIB_BUILD Off)
-endif()
+add_llvm_tool_subdirectory(opt)
+add_llvm_tool_subdirectory(llvm-as)
+add_llvm_tool_subdirectory(llvm-dis)
+add_llvm_tool_subdirectory(llvm-mc)
 
-if(NOT LLVM_USE_INTEL_JITEVENTS )
-  set(LLVM_TOOL_LLVM_JITLISTENER_BUILD Off)
-endif()
+add_llvm_tool_subdirectory(llc)
+add_llvm_tool_subdirectory(llvm-ar)
+add_llvm_tool_subdirectory(llvm-nm)
+add_llvm_tool_subdirectory(llvm-size)
+
+add_llvm_tool_subdirectory(llvm-cov)
+add_llvm_tool_subdirectory(llvm-profdata)
+add_llvm_tool_subdirectory(llvm-link)
+add_llvm_tool_subdirectory(lli)
+
+add_llvm_tool_subdirectory(llvm-extract)
+add_llvm_tool_subdirectory(llvm-diff)
+add_llvm_tool_subdirectory(macho-dump)
+add_llvm_tool_subdirectory(llvm-objdump)
+add_llvm_tool_subdirectory(llvm-readobj)
+add_llvm_tool_subdirectory(llvm-rtdyld)
+add_llvm_tool_subdirectory(llvm-dwarfdump)
+add_llvm_tool_subdirectory(dsymutil)
+add_llvm_tool_subdirectory(llvm-cxxdump)
+if( LLVM_USE_INTEL_JITEVENTS )
+  add_llvm_tool_subdirectory(llvm-jitlistener)
+else()
+  ignore_llvm_tool_subdirectory(llvm-jitlistener)
+endif( LLVM_USE_INTEL_JITEVENTS )
+
+add_llvm_tool_subdirectory(bugpoint)
+add_llvm_tool_subdirectory(bugpoint-passes)
+add_llvm_tool_subdirectory(llvm-bcanalyzer)
+add_llvm_tool_subdirectory(llvm-stress)
+add_llvm_tool_subdirectory(llvm-mcmarkup)
+
+add_llvm_tool_subdirectory(verify-uselistorder)
 
-if(CYGWIN OR NOT LLVM_ENABLE_PIC)
-  set(LLVM_TOOL_LTO_BUILD Off)
-  set(LLVM_TOOL_LLVM_LTO_BUILD Off)
+add_llvm_tool_subdirectory(llvm-symbolizer)
+
+add_llvm_tool_subdirectory(llvm-c-test)
+
+add_llvm_tool_subdirectory(obj2yaml)
+add_llvm_tool_subdirectory(yaml2obj)
+
+add_llvm_tool_subdirectory(llvm-go)
+
+add_llvm_tool_subdirectory(llvm-pdbdump)
+
+if(NOT CYGWIN AND LLVM_ENABLE_PIC)
+  add_llvm_tool_subdirectory(lto)
+  add_llvm_tool_subdirectory(llvm-lto)
+else()
+  ignore_llvm_tool_subdirectory(lto)
+  ignore_llvm_tool_subdirectory(llvm-lto)
 endif()
 
+add_llvm_tool_subdirectory(gold)
+
+add_llvm_external_project(clang)
+add_llvm_external_project(llgo)
+add_llvm_external_project(lld)
+add_llvm_external_project(lldb)
+
 # Automatically add remaining sub-directories containing a 'CMakeLists.txt'
 # file as external projects.
-add_llvm_implicit_projects()
+add_llvm_implicit_external_projects()
 
 set(LLVM_COMMON_DEPENDS ${LLVM_COMMON_DEPENDS} PARENT_SCOPE)