sancov test suite
[oota-llvm.git] / test / CMakeLists.txt
index 50dc98a8121c4e655e23f97ef2afb85f3799f025..9bee504efece68bbc707f12f36adbf1797768a81 100644 (file)
@@ -19,11 +19,12 @@ endif()
 # Set the depends list as a variable so that it can grow conditionally.
 # NOTE: Sync the substitutions in test/lit.cfg when adding to this list.
 set(LLVM_TEST_DEPENDS
-          llvm-config
-          UnitTests
           BugpointPasses
+          FileCheck
           LLVMHello
+          UnitTests
           bugpoint
+          count
           llc
           lli
           lli-child-target
@@ -31,6 +32,7 @@ set(LLVM_TEST_DEPENDS
           llvm-as
           llvm-bcanalyzer
           llvm-c-test
+          llvm-config
           llvm-cov
           llvm-cxxdump
           llvm-diff
@@ -54,14 +56,13 @@ set(LLVM_TEST_DEPENDS
           llvm-split
           llvm-symbolizer
           llvm-tblgen
-          opt
-          FileCheck
-          count
           not
-          yaml-bench
-          yaml2obj
           obj2yaml
+          opt
+          sancov
           verify-uselistorder
+          yaml-bench
+          yaml2obj
         )
 
 # If Intel JIT events are supported, depend on a tool that tests the listener.