[mips] For the FP64A ABI, odd-numbered double-precision moves must not use mtc1/mfc1.
[oota-llvm.git] / test / CMakeLists.txt
index 4effaf727c4ed4a32f710b1c07633d870d5ec3fb..3e08a16389451643f1b0b0be71cf2832f5aabcfa 100644 (file)
@@ -13,32 +13,39 @@ if(NOT LLVM_BUILD_TOOLS)
 endif()
 
 # Set the depends list as a variable so that it can grow conditionally.
+# NOTE: Sync the substitutions in test/lit.cfg when adding to this list.
 set(LLVM_TEST_DEPENDS
+          llvm-config
           UnitTests
           BugpointPasses
           LLVMHello
+          bugpoint
           llc
           lli
+          lli-child-target
           llvm-ar
           llvm-as
           llvm-bcanalyzer
+          llvm-c-test
           llvm-cov
           llvm-diff
           llvm-dis
           llvm-extract
           llvm-dwarfdump
           llvm-link
-          llvm-lto
+          llvm-lto
           llvm-mc
           llvm-mcmarkup
           llvm-nm
+          llvm-size
           llvm-objdump
+          llvm-profdata
           llvm-readobj
           llvm-rtdyld
           llvm-symbolizer
+          llvm-tblgen
           macho-dump
           opt
-          profile_rt-shared
           FileCheck
           count
           not