[OCaml] Expose Llvm.get_operand_use.
[oota-llvm.git] / test / CMakeLists.txt
index d900471d570fef572470e1f746a8f6e733800d00..2b3a618a3aede2a9dff4792cbec1d77918175aa6 100644 (file)
@@ -13,16 +13,20 @@ if(NOT LLVM_BUILD_TOOLS)
 endif()
 
 # Set the depends list as a variable so that it can grow conditionally.
+# NOTE: Sync the substitutions in test/lit.cfg when adding to this list.
 set(LLVM_TEST_DEPENDS
+          llvm-config
           UnitTests
           BugpointPasses
           LLVMHello
+          bugpoint
           llc
           lli
           lli-child-target
           llvm-ar
           llvm-as
           llvm-bcanalyzer
+          llvm-c-test
           llvm-cov
           llvm-diff
           llvm-dis
@@ -33,18 +37,22 @@ set(LLVM_TEST_DEPENDS
           llvm-mc
           llvm-mcmarkup
           llvm-nm
+          llvm-size
           llvm-objdump
+          llvm-profdata
           llvm-readobj
           llvm-rtdyld
           llvm-symbolizer
+          llvm-tblgen
+          llvm-vtabledump
           macho-dump
           opt
-          profile_rt-shared
           FileCheck
           count
           not
           yaml2obj
           obj2yaml
+          verify-uselistorder
         )
 
 # If Intel JIT events are supported, depend on a tool that tests the listener.