Temporarily Revert "Nuke the old JIT." as it's not quite ready to
[oota-llvm.git] / test / CMakeLists.txt
index 3da7c181fa7774e39f97506dd9ef0563d7bc17dd..2b3a618a3aede2a9dff4792cbec1d77918175aa6 100644 (file)
@@ -13,22 +13,47 @@ if(NOT LLVM_BUILD_TOOLS)
 endif()
 
 # Set the depends list as a variable so that it can grow conditionally.
-set(LLVM_TEST_DEPENDS UnitTests
-          BugpointPasses LLVMHello
-          llc lli llvm-ar llvm-as
-          llvm-bcanalyzer llvm-diff
-          llvm-dis llvm-extract llvm-dwarfdump
+# NOTE: Sync the substitutions in test/lit.cfg when adding to this list.
+set(LLVM_TEST_DEPENDS
+          llvm-config
+          UnitTests
+          BugpointPasses
+          LLVMHello
+          bugpoint
+          llc
+          lli
+          lli-child-target
+          llvm-ar
+          llvm-as
+          llvm-bcanalyzer
+          llvm-c-test
+          llvm-cov
+          llvm-diff
+          llvm-dis
+          llvm-extract
+          llvm-dwarfdump
           llvm-link
+          llvm-lto
           llvm-mc
           llvm-mcmarkup
           llvm-nm
+          llvm-size
           llvm-objdump
+          llvm-profdata
           llvm-readobj
           llvm-rtdyld
-          macho-dump opt
-          profile_rt-shared
-          FileCheck count not
-          yaml2obj)
+          llvm-symbolizer
+          llvm-tblgen
+          llvm-vtabledump
+          macho-dump
+          opt
+          FileCheck
+          count
+          not
+          yaml2obj
+          obj2yaml
+          verify-uselistorder
+        )
 
 # If Intel JIT events are supported, depend on a tool that tests the listener.
 if( LLVM_USE_INTEL_JITEVENTS )