Taints the non-acquire RMW's store address with the load part
[oota-llvm.git] / test / CMakeLists.txt
index 464a6f0161a97a4f9622b045a8a6728a230c2896..138450ba8e0270a1cd624b2a3175256261bf1dcb 100644 (file)
@@ -19,11 +19,12 @@ endif()
 # Set the depends list as a variable so that it can grow conditionally.
 # NOTE: Sync the substitutions in test/lit.cfg when adding to this list.
 set(LLVM_TEST_DEPENDS
-          llvm-config
-          UnitTests
           BugpointPasses
+          FileCheck
           LLVMHello
+          UnitTests
           bugpoint
+          count
           llc
           lli
           lli-child-target
@@ -31,12 +32,14 @@ set(LLVM_TEST_DEPENDS
           llvm-as
           llvm-bcanalyzer
           llvm-c-test
+          llvm-config
           llvm-cov
           llvm-cxxdump
           llvm-diff
           llvm-dis
           llvm-dsymutil
           llvm-dwarfdump
+          llvm-dwp
           llvm-extract
           llvm-lib
           llvm-link
@@ -45,6 +48,7 @@ set(LLVM_TEST_DEPENDS
           llvm-mcmarkup
           llvm-nm
           llvm-objdump
+          llvm-pdbdump
           llvm-profdata
           llvm-ranlib
           llvm-readobj
@@ -53,15 +57,13 @@ set(LLVM_TEST_DEPENDS
           llvm-split
           llvm-symbolizer
           llvm-tblgen
-          macho-dump
-          opt
-          FileCheck
-          count
           not
-          yaml-bench
-          yaml2obj
           obj2yaml
+          opt
+          sancov
           verify-uselistorder
+          yaml-bench
+          yaml2obj
         )
 
 # If Intel JIT events are supported, depend on a tool that tests the listener.