Print a warning message if compiler-rt can't be built because of old CMake version...
[oota-llvm.git] / projects / CMakeLists.txt
index 36751cd31dac930297118a9bf9c971338fe6cba7..c19bb679d186e1a51cb9533547f1f8d66f407fe5 100644 (file)
@@ -13,7 +13,10 @@ endforeach(entry)
 
 # Also add in the compiler-rt tree if present and we have a sufficiently
 # recent version of CMake.
-if(${CMAKE_VERSION} VERSION_GREATER 2.8.7 AND
-   ${LLVM_BUILD_RUNTIME})
-  add_llvm_external_project(compiler-rt)
+if(${LLVM_BUILD_RUNTIME})
+  if(${CMAKE_VERSION} VERSION_GREATER 2.8.7)
+    add_llvm_external_project(compiler-rt)
+  else()
+    message(WARNING "Can't build compiler-rt, CMake 2.8.8 required!")
+  endif()
 endif()