Revert "r216914 - Revert: [APFloat] Fixed a bug in method 'fusedMultiplyAdd'"
[oota-llvm.git] / projects / CMakeLists.txt
index f0890bb867986446dd79fdef8384bc3366f5e1b1..8d244fd49edd555c1417d488de98fd5b670b5e7c 100644 (file)
@@ -6,7 +6,8 @@ foreach(entry ${entries})
   if(IS_DIRECTORY ${entry} AND EXISTS ${entry}/CMakeLists.txt)
     if((NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt) AND
        (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/dragonegg) AND
-       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx))
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxxabi))
       add_subdirectory(${entry})
     endif()
   endif()
@@ -19,11 +20,10 @@ if(${LLVM_BUILD_RUNTIME})
   # fixed.
   if(NOT MSVC)
     add_llvm_external_project(libcxx)
+    add_llvm_external_project(libcxxabi)
   endif()
-  if(${CMAKE_VERSION} VERSION_GREATER 2.8.7)
+  if(NOT LLVM_BUILD_EXTERNAL_COMPILER_RT)
     add_llvm_external_project(compiler-rt)
-  else()
-    message(WARNING "Can't build compiler-rt, CMake 2.8.8 required!")
   endif()
 endif()