R600: Make sure to inline all internal functions
[oota-llvm.git] / projects / CMakeLists.txt
index de06b78423c575d3cf2a05a9a21060ed5a32482b..8d244fd49edd555c1417d488de98fd5b670b5e7c 100644 (file)
@@ -5,7 +5,9 @@ file(GLOB entries *)
 foreach(entry ${entries})
   if(IS_DIRECTORY ${entry} AND EXISTS ${entry}/CMakeLists.txt)
     if((NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt) AND
-       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx))
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/dragonegg) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxxabi))
       add_subdirectory(${entry})
     endif()
   endif()
@@ -14,10 +16,15 @@ endforeach(entry)
 # Also add in libc++ and compiler-rt trees if present (and we have
 # a sufficiently recent version of CMake where required).
 if(${LLVM_BUILD_RUNTIME})
-  add_llvm_external_project(libcxx)
-  if(${CMAKE_VERSION} VERSION_GREATER 2.8.7)
+  # MSVC isn't quite working with libc++ yet, disable it until issues are
+  # fixed.
+  if(NOT MSVC)
+    add_llvm_external_project(libcxx)
+    add_llvm_external_project(libcxxabi)
+  endif()
+  if(NOT LLVM_BUILD_EXTERNAL_COMPILER_RT)
     add_llvm_external_project(compiler-rt)
-  else()
-    message(WARNING "Can't build compiler-rt, CMake 2.8.8 required!")
   endif()
 endif()
+
+add_llvm_external_project(dragonegg)