Taints upcoming store and adds bogus conditional branches else where. Now as a separa...
[oota-llvm.git] / projects / CMakeLists.txt
index fc6483ca35620474c5748b902b6e8613362bde74..4839dd396706fa28ef4b8139df5b2a2450994aa5 100644 (file)
@@ -5,7 +5,11 @@ file(GLOB entries *)
 foreach(entry ${entries})
   if(IS_DIRECTORY ${entry} AND EXISTS ${entry}/CMakeLists.txt)
     if((NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt) AND
-       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx))
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/dragonegg) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxxabi) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libunwind) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/test-suite))
       add_subdirectory(${entry})
     endif()
   endif()
@@ -17,11 +21,15 @@ if(${LLVM_BUILD_RUNTIME})
   # MSVC isn't quite working with libc++ yet, disable it until issues are
   # fixed.
   if(NOT MSVC)
+    # libc++ uses the libc++abi target names so libc++abi should be added
+    # first.
+    add_llvm_external_project(libcxxabi)
     add_llvm_external_project(libcxx)
+    add_llvm_external_project(libunwind)
   endif()
-  if(${CMAKE_VERSION} VERSION_GREATER 2.8.7)
+  if(NOT LLVM_BUILD_EXTERNAL_COMPILER_RT)
     add_llvm_external_project(compiler-rt)
-  else()
-    message(WARNING "Can't build compiler-rt, CMake 2.8.8 required!")
   endif()
 endif()
+
+add_llvm_external_project(dragonegg)