Taints relaxed loads to enforce load/store ordering
[oota-llvm.git] / projects / CMakeLists.txt
index 67943c2e9a36460fa0b14ccbb4caa6dad7ec8cc2..4839dd396706fa28ef4b8139df5b2a2450994aa5 100644 (file)
@@ -6,7 +6,10 @@ foreach(entry ${entries})
   if(IS_DIRECTORY ${entry} AND EXISTS ${entry}/CMakeLists.txt)
     if((NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt) AND
        (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/dragonegg) AND
-       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx))
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxxabi) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libunwind) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/test-suite))
       add_subdirectory(${entry})
     endif()
   endif()
@@ -18,9 +21,15 @@ if(${LLVM_BUILD_RUNTIME})
   # MSVC isn't quite working with libc++ yet, disable it until issues are
   # fixed.
   if(NOT MSVC)
+    # libc++ uses the libc++abi target names so libc++abi should be added
+    # first.
+    add_llvm_external_project(libcxxabi)
     add_llvm_external_project(libcxx)
+    add_llvm_external_project(libunwind)
+  endif()
+  if(NOT LLVM_BUILD_EXTERNAL_COMPILER_RT)
+    add_llvm_external_project(compiler-rt)
   endif()
-  add_llvm_external_project(compiler-rt)
 endif()
 
 add_llvm_external_project(dragonegg)