Add LICENSE.TXT covering contributions made by ARM.
[oota-llvm.git] / projects / CMakeLists.txt
index c4567a35b08cd7a46911839d0825be520f0c5b1c..36751cd31dac930297118a9bf9c971338fe6cba7 100644 (file)
@@ -14,7 +14,6 @@ endforeach(entry)
 # Also add in the compiler-rt tree if present and we have a sufficiently
 # recent version of CMake.
 if(${CMAKE_VERSION} VERSION_GREATER 2.8.7 AND
-   IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt AND
-   EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt/CMakeLists.txt)
-  add_subdirectory(compiler-rt)
+   ${LLVM_BUILD_RUNTIME})
+  add_llvm_external_project(compiler-rt)
 endif()