Enable libcxx as part of the top level CMake build when it is checked
[oota-llvm.git] / projects / CMakeLists.txt
index c19bb679d186e1a51cb9533547f1f8d66f407fe5..de06b78423c575d3cf2a05a9a21060ed5a32482b 100644 (file)
@@ -11,9 +11,10 @@ foreach(entry ${entries})
   endif()
 endforeach(entry)
 
-# Also add in the compiler-rt tree if present and we have a sufficiently
-# recent version of CMake.
+# Also add in libc++ and compiler-rt trees if present (and we have
+# a sufficiently recent version of CMake where required).
 if(${LLVM_BUILD_RUNTIME})
+  add_llvm_external_project(libcxx)
   if(${CMAKE_VERSION} VERSION_GREATER 2.8.7)
     add_llvm_external_project(compiler-rt)
   else()