[cmake] Use the external project machinery for libcxxabi so that it can
[oota-llvm.git] / projects / CMakeLists.txt
index e23a27705620b0206d22988a8ed01edd1c049002..8d244fd49edd555c1417d488de98fd5b670b5e7c 100644 (file)
@@ -6,7 +6,8 @@ foreach(entry ${entries})
   if(IS_DIRECTORY ${entry} AND EXISTS ${entry}/CMakeLists.txt)
     if((NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/compiler-rt) AND
        (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/dragonegg) AND
-       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx))
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxx) AND
+       (NOT ${entry} STREQUAL ${CMAKE_CURRENT_SOURCE_DIR}/libcxxabi))
       add_subdirectory(${entry})
     endif()
   endif()
@@ -19,6 +20,7 @@ if(${LLVM_BUILD_RUNTIME})
   # fixed.
   if(NOT MSVC)
     add_llvm_external_project(libcxx)
+    add_llvm_external_project(libcxxabi)
   endif()
   if(NOT LLVM_BUILD_EXTERNAL_COMPILER_RT)
     add_llvm_external_project(compiler-rt)