Make getNodeValueTypes methods public.
[oota-llvm.git] / llvm.spec
index 0ff78198c224286b2ef93f3bcfa5e18671f9e3b7..50d265a87e7d6aa4d1fb82754015ad5dde8b1f3b 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -1,6 +1,6 @@
 Summary: Static and JIT research compiler infrastructure
 Name: llvm
-Version: 1.2
+Version: 1.6cvs
 Release: 0
 License: U of Illinois/NCSA Open Source License
 Group: Development/Languages
@@ -12,11 +12,13 @@ BuildRoot: %{_tmppath}/%{name}-root
 Requires: /sbin/ldconfig
 
 %description
-LLVM is a new infrastructure designed for compile-time, link-time, runtime,
+LLVM is a compiler infrastructure designed for compile-time, link-time, runtime,
 and "idle-time" optimization of programs from arbitrary programming languages.
-LLVM is written in C++ and has been developed since 2000 at the
-University of Illinois. It currently supports compilation of C and C++
-programs, using front-ends derived from GCC 3.4.
+LLVM is written in C++ and has been developed since 2000 at the University of
+Illinois. It currently supports compilation of C and C++ programs, using
+front-ends derived from GCC 3.4. The compiler infrastructure includes mirror
+sets of programming tools as well as libraries with equivalent
+functionality.
 
 %prep
 %setup -q -n llvm
@@ -27,7 +29,9 @@ programs, using front-ends derived from GCC 3.4.
 --bindir=%{_bindir} \
 --datadir=%{_datadir} \
 --includedir=%{_includedir} \
---libdir=%{_libdir}
+--libdir=%{_libdir} \
+--enable-optimized \
+--enable-assertions \
 make
 
 %install
@@ -51,6 +55,10 @@ rm -rf %{buildroot}
 %{_includedir}/llvm
 
 %changelog
+* Fri Apr 07 2006 Reid Spencer
+- Make the build be optimized+assertions
+* Fri May 13 2005 Reid Spencer
+- Minor adjustments for the 1.5 release
 * Mon Feb 09 2003 Brian R. Gaeke
 - Initial working version of RPM spec file.