Protection against stack-based memory corruption errors using SafeStack
[oota-llvm.git] / lib / Transforms / Instrumentation / CMakeLists.txt
index eaa3a4000f887810960ac7c3a1426803f15e0c4d..9b81f4bb161961f8e73ef0eb4f6993de555d7455 100644 (file)
@@ -1,13 +1,17 @@
 add_llvm_library(LLVMInstrumentation
   AddressSanitizer.cpp
-  EdgeProfiling.cpp
-  FunctionBlackList.cpp
+  BoundsChecking.cpp
+  DataFlowSanitizer.cpp
   GCOVProfiling.cpp
+  MemorySanitizer.cpp
   Instrumentation.cpp
-  OptimalEdgeProfiling.cpp
-  PathProfiling.cpp
-  ProfilingUtils.cpp
+  InstrProfiling.cpp
+  SafeStack.cpp
+  SanitizerCoverage.cpp
   ThreadSanitizer.cpp
+
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Transforms
   )
 
 add_dependencies(LLVMInstrumentation intrinsics_gen)