Protection against stack-based memory corruption errors using SafeStack
[oota-llvm.git] / lib / Transforms / Instrumentation / CMakeLists.txt
index d7c518d282f813d1fd5076c290a3ba2308246298..9b81f4bb161961f8e73ef0eb4f6993de555d7455 100644 (file)
@@ -1,6 +1,17 @@
 add_llvm_library(LLVMInstrumentation
-  BlockProfiling.cpp
-  EdgeProfiling.cpp
-  ProfilingUtils.cpp
-  RSProfiling.cpp
+  AddressSanitizer.cpp
+  BoundsChecking.cpp
+  DataFlowSanitizer.cpp
+  GCOVProfiling.cpp
+  MemorySanitizer.cpp
+  Instrumentation.cpp
+  InstrProfiling.cpp
+  SafeStack.cpp
+  SanitizerCoverage.cpp
+  ThreadSanitizer.cpp
+
+  ADDITIONAL_HEADER_DIRS
+  ${LLVM_MAIN_INCLUDE_DIR}/llvm/Transforms
   )
+
+add_dependencies(LLVMInstrumentation intrinsics_gen)